Самоучитель по Office XP

 

Упражнение 6. Применение функций

До сих пор вы пользовались только функциями СУММ, СРЗНАЧ, СЧЕТ и МАКС. Давайте рассмотрим на примере некоторые функции из разряда текстовых и логических, а также функции работы с датой и временем. Результат всех вычислений, которые будут выполнены в этом упражнении.
  1.  В листе Формулы выделите и скопируйте ячейки Bl:Gl.
  2.  Разверните лист ЛистЗ (Sheet3).
  3.  Щелкните правой кнопкой мыши на ячейке А1 и выберите в контекстном меню команду Вставить.
  4. Введите в ячейку A3 формулу =ЛЕВСИМВ(А1 ;3) (=LEFT(A1; 3)). Эта формула возвращает три левых символа ячейки А1.
  5.  Перетащите угловой маркер выделения вправо, чтобы рамка охватила ячейки A3:F3. Теперь в третью строку выводятся сокращенные варианты названий месяцев из ячеек первой строки.
  6.  Щелкните наячейкеНЗ и введите формулу =СЦЕПИТЬ(ВЗ ;D3) (CONCATENATE (ВЗ ; D3)). В ячейке НЗ появится объединение строк Фев и Апр.
  7.  В ячейку А8 введите формулу =ТДАТА () (=NOW ()) и нажмите клавишу Enter. В ней тут же появятся текущие дата и время.
  8.  Введите в ячейки с В8 по В13 формулы = ГОД (А8) (=YEAR(A8)), =МЕСЯЦ(А8) (=MONTH (А8)),=ДЕНЬ(А8)(=DAY(А8)),=ЧАС(А8)(=HOUR(A8)),=МИНУТЫ(А8) (=MINUTE(A8)) и =СЕКУНДЫ(А8) (=SECOND (A8)). В этих ячейках появятся по отдельности все шесть компонентов текущих даты и времени.
  9.  Дважды щелкните на ячейке А8, чтобы перевести ее в режим редактирования.
  10.  Щелкните на кнопке Ввод, расположенной слева от строки формул. Эта операция приведет к обновлению значения в ячейке А8, что повлияет и на числа ячеек В8:В13.
Теперь давайте выполним логическую операцию.
  1. ВведитевячейкуА4формулу=ЕСЛИ(АЗ="Фев"; "Да"; "Нет") (=IF(АЗ="Фев"; " Да "; " Н е т ")). Эта операция сравнивает значение ячейки A3 с текстовой строкой Фев. В случае равенства выводится текст второго аргумента — Да. В случае неравенства выводится текст третьего аргумента — Нет. Так как в ячейке A3 присутствует текст Янв, то результатом этой операции будет значение Нет.
  2.  Растяните маркер ячейки А4 вправо, чтобы рамка охватила диапазон A4:F4. Теперь формулы строки 4 проверяют ячейки строки 3 на совпадение их содержимого со строкой Фев. Как видите, слово Да появилось только в столбце В.
Знаки, которые используются в Excel для сравнения величин, перечислены в табл. 10.8. Обратите внимание, что текстовые строки, выступающие в качестве аргументов функций, должны заключаться в двойные кавычки. Примечание

Текстовые строки равны, если попарно совпадают все их символы, в противном случае строки не равны. Одна текстовая строка больше другой, если в ней код первого символа, несовпадающего в обеих строках, больше кода того же символа во второй строке.

ТАБЛИЦА 10.8. Знаки сравнения
Знак Значение 
= Равно
> Больше
< Меньше
>= Больше или равно
<= Меньше или равно
<> Не равно