Самоучитель по Office XP

 

Упражнение 4. Копирование формул

Иногда требуется провести одинаковые расчеты с разными группами ячеек. В такой ситуации можно сэкономить время и скопировать формулы, так как Excel поддерживает относительную адресацию ячеек. В строке 10 нашего примера уже есть формулы, рассчитывающие относительный прирост продаж по месяцам для клиента Фантом. Давайте скопируем их, чтобы получить таблицу прироста продаж для всех клиентов.
  1.  Щелкните на любой непустой ячейке в строке 10. Вы увидите, что выбранная формула ссылается на ячейки строки 2.
  2.  Выделите диапазон B10:F10.
  3.  Нажатием клавиш Ctrl+C скопируйте ячейки.
  4. Щелкните на ячейке В11, а затем на кнопке Вставить панели инструментов Стандартная. Появится еще одна строка ячеек с формулами. Щелкните на любой из них и взгляните в строку формул. Вы увидите, что формулы новых ячеек ссылаются на данные строки 3, как показано на рис. 10.9.
  5.  Щелкните на ячейке В 12 и нажмите клавиши Ctrl+V, чтобы вставить еще одну строку. Формулы этой строки уже будут ссылаться на данные строки 4. Таким образом, номера ячеек данных изменяются ровно на столько клеток, на сколько смещается вставляемая формула.

Рис. 10.9. Копирование формул Примечание

Обратите внимание, что вырезание ячеек с формулами с последующей их вставкой в другое место листа никак не изменяет ссылки на данные.

  1.  Вставьте тот же самый фрагмент в ячейки В13 и В14.
  2.  Скопируйте заголовки строк из ячеек А2:А6 в ячейки А10:А14.
Примечание

Обычно Excel формирует относительные ссылки на ячейки. Но иногда нужно сослаться в формуле на клетку с константой, которая не должна меняться при копировании формулы в другую ячейку или при перемещении исходных данных. В этом случае пользуйтесь абсолютными ссылками, которые отличаются от относительных наличием символа $ перед буквой столбца, номером строки или перед обеими этими характеристиками, например $Е$15. В такой ссылке не изменяется та часть, перед которой стоит знак $. Например, копируя формулу =СУММ($В$2:$0$6) (=SUM($B$2:$G$6)) в другую ячейку, вы получите тот же самый результат, что и в исходной клетке формулы.

Операция суммирования строк или столбцов — одна из наиболее распространенных. Чтобы создать формулы сумм строк или столбцов, не нужно даже копировать ячейки, Excel предлагает еще более быстрый способ.
  1.  Выделите группу ячеек 12:16.
  2. Щелкните на кнопке Автосумма (AutoSum) панели инструментов Стандартная.
  3. Осталось только ввести в ячейку II заголовок Итого, и столбец общей суммы продаж для всех пяти клиентов готов (рис. 10.10).
Примечание  

Обратите внимание на значок вставки, появляющийся в правом нижнем углу вставленного фрагмента. Благодаря ему легко выбрать вариант вставки — хотите ли вы вставить число из копируемой ячейки или абсолютную либо относительную ссылки, нужно ли сохранять формат исходной ячейки и т. д.